
NVivo 7 Tutorial 5: 

Nodes and Coding 
Nodes – the containers for ideas and coding – should be familiar by now. They were 
explained in Tutorial 3, where the exercises created nodes to hold references to all the 
material about a case. That tutorial also taught one sort of “descriptive coding”, the 
storing of attributes (e.g. gender) and assigning of the relevant value (e.g. female) to 
each case. Revisit that tutorial for techniques of doing this manually or by table 
import. 

But when qualitative researchers code, they are usually doing something 
interpretative, not merely descriptive. This tutorial shows techniques for doing 
qualitative coding. It introduces ways to create the categories for thinking about your 
data, to identify new categories and ideas from the data, and to gather material about 
those ideas.  

In it you will learn how to: 

• Create nodes from prior ideas; 

• Code at existing nodes; 

• Create nodes and code “up” from meanings in the data; 

• Create and name new nodes “in-vivo”, from the words in the data; 

• View coded data and its context; 

• Work with coded data, coding on to other nodes; 

• Auto-code data records that are structured, using headings. 

For advice about creating categories and coding, explanation of the differences 
between qualitative and quantitative coding and the purposes for which qualitative 
researchers use coding, go to Chapter 5 of Handling Qualitative Data. 

For more detail about coding processes in NVivo 7, go to the online Help. 

Focusing on a document 
To start this tutorial, as with the previous one, you need to concentrate on one 
document in your project. 

It may be the document you worked with in the previous tutorial; it’s interesting (but 
not necessary) to combine writing and linking techniques with those of coding. If you 
want to move to a different document, read it through before you begin coding on 
computer Now, go back to the start of your document. 

The simplest goals of coding are to identify the categories for thinking about your 
data and to gather at a category all the data about it.  

In these examples, the document is one of the interviews in the sample project on 
Volunteering, the interview with “Anna”. You can conduct these exercises with any 
source (document, external or memo) in your own project.  



 

1. Making a node 
Where do the categories for thinking about your research come from? Researchers 
coding in qualitative research often create categories, “down” from their research 
questions and designs, before they start exploring the data. In NVivo, those categories 
and the coding you do are stored at nodes. 

The node areas 
In the Navigation View, click Nodes to view the different areas for nodes.  

These provide folders for: 

• nodes “Free” of organization 
• nodes in catalogs or “Trees” 

• Cases (see Tutorial 3) 
• nodes for coding Relationships

• Matrices (see Tutorial 9)
• and to see nodes all in one list, 

All Nodes.

 

 
The next tutorial covers Relationships and the managing of nodes in trees. Here 
you will code just at Free Nodes. 

To make a node 
1. Using a memo or model in NVivo, or if you prefer, paper, or a white board, 

sketch a beginning list of the categories your project is about – topics or ideas 
about which you wish to collect data. (For example, in the Volunteering 
project you might be curious about what motivates volunteers or the images of 
volunteering.) 

2. Click on Free Nodes. And click in the empty List View.  

3. Just as for making new documents, there are many ways to make a new node. 

• From Project menu OR Context menu,  select Create a Free Node.  
• OR use the New button, to create a New Free Node in This Folder.   
• OR use the fast key, Ctrl+Shift+A.  
 

 
4. Name the new node, and if you wish, add a description.  



 
5. Check the information in the List View. Note that the node is showing that it 

codes  no Sources and (not surprisingly!) has no references to content. It is a 
useful habit to scan the nodes you create, watching for the ones that show no 
sources coded there, and wondering why they don’t have coding. 

 
6. Continue creating and naming nodes for any broad topics or concepts you 

expect that your project will require. If wish to change the properties of a 
node, select Free Node Properties from Project or Context menu. 

7. You changed your mind? Select Delete Node from the Project or Context 
menu – or hit the Delete key. 

You may wish to continue reading and looking for data about the categories for which 
you already created nodes.  

Placing your nodes 
In Tutorial 6 you will learn the ways of moving nodes around, and using tree 
structures to represent their logical relations. If you wish to tidy the “starter” nodes 
you’ve created, go to that tutorial for the techniques of cut, copy, merge and paste. 

 You may later wish to revisit the early ideas as they were represented by these 
first nodes. They offer a way of recalling your early assumptions, what you thought then 
would be important, what the literature alerted you to. One way is to make a Set of all 
the nodes that you create at this starting-out stage of your project. But if later you 
delete a node, of course its shortcut will be deleted from that set. Another way is to 
store a report o your nodes at this stage, and later stages. (Go to Tutorial 6 for ways of 
reporting your nodes.) 



 

2. Coding at an existing node 
To set the screen to suit your coding 

1. In the folder of Sources, select Documents and from the List View select the 
document you wish to read and code. Double click to open it in the Detail 
View. This window, in which you annotated and linked a document in the 
previous tutorial, also offers several ways of coding.  

2. Click on Nodes>Free Nodes and the List View shows your Free Nodes. 

3. Now set the screen to suit you. Most researchers when coding wish to see all 
their nodes displayed beside the content being coded. From the View menu, 
select Detail View>Right, to see the panels of the Navigation Window 
vertically. 

 
4. The Coding toolbar offers ways of selecting nodes and buttons for coding 

functions. You may wish now to move it to the bottom of the Detail View. 

 
5. Hover over the icons, or go to the end of the toolbar to check the names for 

each option. You may wish to hide some of them – but first, check what they 
do! One will be wanted often: the green tick over lines of text that says Code. 

Now you are ready to code at your existing node, in any of several ways. You can 
drag and drop, use the menus or use that coding bar. 



To code by drag and drop at an existing node 
1. Select some text that you wish to code at the Free Node you have created.  

2. Drag the text onto the node. (the mouse icon shows that it is being “dragged” 
and then that it has “dropped” what it was dragging.) 

 

 

To code at an existing node using the menus 
1. Select some more text that you wish to code at an existing node. 

2. From the right mouse Context Menu or the Code menu, select Code>Code 
Selection at Existing Nodes. Note the other options: to code at a new node, 
the node currently showing in the coding bar, or to code at any of these whole 
source(s). 

 
 

3. NVivo asks what node do you wish to code at, by offering the Select Project 
Items box. Select the node, or if you wish more than one node, and click OK.  

4. The node selected appears in the slot for a node name in the Coding toolbar.  

 

To code further content at this node, select it and click the Code icon.  



To code with the coding bar at an existing node 
The Coding Bar can be used directly. Check if this suits your style. 

1. Select some more text that you wish to code at an existing node. 

2. Check what node is in the slot in the coding bar. When you click the Code 
button, it will code at the node showing there. 

3. To select a different node – or nodes – to code at, set the coding bar to Code 
At| Name, and click the […] button to Select Nodes. 

 
4. From the Select Project Items box select the node or any number of nodes at 

which you wish to code this text. 

5. Click . Note that if you change your mind, the Uncode icon is the next 
on the bar! 

 

Those prior categories will probably not suffice for what you are now seeing in the 
data. Researchers sometimes start this way.  

But almost always, most categories are discovered and created “up” from the data, as 
they read and interpret data sources. This is the most usual form of qualitative coding. 

You could of course create new nodes as you discover new categories, and continue 
as above, making the nodes first, and then coding at them by dragging the text to them 
or selecting them and clicking Code. 

But NVivo allows you to combine these processes, making the nodes and coding at 
them as a single task. As you work with your data, you’ll make a lot of nodes! 

This is the next task. If you are new to qualitative coding, you may like to follow the 
steps in Chapter 5 of Handling Qualitative Data. 

 



3. Creating new nodes “up” from the data 
As you read the document, you may see a category “emerge”.  You can make the 
node and do the coding as one task, either with the menus or with the Coding Bar. 

To create a node by coding (using the menus) 
1. Highlight some text you wish to code.  

2. From the Context Menu, select Code Selection at New Node 

3. In the New Free Node box, type a name for this node – the category or theme 
- and, if you wish, a description. Click OK.   

 
4. The node is created and the coding done. Your new node appears in the Free 

Nodes List View and in the Name slot on the Coding bar. 

5. If you wish to place the new node in another node area, use Cut and Paste as 
described in the next Tutorial. 

 The process you just conducted is often the most exciting and important one early 
in a project. It’s worth becoming very familiar with this swift task, so the creation of a 
node and coding of data at it feels like thinking aloud.  

Note there is a shortcut – Ctrl+F3 – for coding a selection at a new node, and when the 
New Free Node box appears, if you wish to place your new node in Free Nodes, you 
need only type the name and press return – the rest is done for you.  

Try working through some rich data, making new nodes as they occur to you, using the 
shortcut, type name, press return.  

To create a new node whilst coding (using the Coding Bar) 
1. Highlight some text you wish to code.  

2. On the Coding Bar, check that the slot is set to Name. 

3. Type the name for this node.  (If a name is in the slot, highlight and type over.) 
Select the node area it will be in. 

 



4. Press Return (that’s fastest!) or click Code.   

5. The node is created and the coding done. 

To create an In Vivo node and code at it 
You can also create the new node by naming it with the word(s) in the text you are 
coding.  

This is called “in vivo” coding, a technique very important to researchers who wish to 
record the categories emerging from their data (see Handling Qualitative Data p.95.) 
It’s useful when the data provide specially suggestive or meaningful concepts. For 
example, in the Volunteering project, Anna used the term “self worth” to explain 
motivation to volunteer, a new idea which you might like to store. 

 When you do in vivo coding, you name the new node with all the text you selected. 
Make the selection brief and relevant – long node names are awkward to use. 

1. Highlight a word or a few words in the text with which you would like to name 
a node.  

2.   Click the “Code In Vivo” button on the coding bar, (or use 
the Code or Context menus) 

3. The node is created (in Free Nodes) and the coding done. Your new node 
appears in the Free Nodes List View and in the Name slot on the Coding bar, 
so you can code again at that node immediately.  

4. Note that a shortcut is Ctrl+F8. Create a new node using that shortcut. 

 



4. Viewing your coding  
There are many reasons why you may wish to see what coding you’ve done, or what 
content is coded at a node – for example, to review your coding, compare with a 
colleague’s coding, browse to check what else is coded in this source at that node, or 
simply to get back to coding where you left off.  

NVivo provides two ways to view your coding as you work. Both are on the View 
toolbar (and the View menu and right mouse Context menu).  

When you are in the Detail View of a source or node, Highlight and Coding Stripes 
are available.  

 
 

To Highlight Coding  
1. In the Detail View of the document you coded, click Highlight.                                    

(or select Highlight from the View menu). 

2. Select the option you want 

 
 

3. In the Select Project Items window, select the node or nodes you are 
interested in. The coded text is highlighted yellow.  

Why would you select Coding for All Nodes? This will show you everything 
that has been coded – and thus everything you haven’t coded yet – a useful 
way to see how your coding is progressing! 



 The whole document may be highlighted when you select Coding for All Nodes. 
Why? Probably, as in Anna’s interview, the entire content is coded at a Case node.  
To exclude Case Nodes (or any other node type you don’t want), in the left pane of 
the Select Project Items window, click Automatically select subfolders, and then 
select all the folders whose nodes you want highlighted. 

.  

To use Coding Stripes  
NVivo will show in the right margin of a Detail View (source or node) colored lines 
that show where content is coded at up to seven nodes, and a grayscale line that shows 
the Coding Density for that content. 

1. In the Detail View of the document you coded, click the icon for Coding 
Stripes, or select from the Project menu or Context menu. 

 
2. Select to Show Nodes Coding Item. The Select Project Item box will 

appear.  

3. Select which nodes you are interested in and click OK. The stripes appear for 
those nodes. If you code some more, at the nodes for which you are showing 
stripes, the lines will update. 

4. In Detail View, the coding stripes appear where there is coding at each 
selected node. Each selected node will be marked by its specific colored line 
throughout Detail View, so you can scan for coding at each.  



 
5. Hover over any stripe to see the node’s folder and full name.  

6. Right mouse to select to Highlight Coding at that node throughout the Detail 
View, to Open Node or Uncode. 

Explore the options so you can use the stripes strategically. Two tips may assist: 

• To use coding stripes rapidly to view current coding, select to show Nodes 
Recently Coding Item. 

• Show stripes for just a Selection to focus on nodes coding that passage. Most 
sources or nodes will have coding from a large number of nodes, but if you 
make a small selection, you will most clearly see what codes it. 

To use the coding density stripe 
The Coding Density stripe is shaded to indicate number of nodes coding this segment 
of the source content. Hover over the stripe to see all the node names.  

If you wish only to monitor what coding at any of your nodes applies to the content, 
without showing the colored stripes for particular nodes, from the View menu or the 
Coding Stripes icon, select Show Coding Density. 

The Coding Density Stripe offers a quick way to check on the state of your coding. 

 You went off for coffee and need to know where your coding work had taken you in 
a source? Show the Coding Density stripe and it will be obvious! (Remember that if you 
coded the source entirely at a case node there will be at least one node coding past 
where you had worked before coffee.) Alternative tricks: place an annotation noting 
things to remember when you return to the coding – you can use a Text Search Query to 
search just annotations in just one source for a word you inserted. Or simply edit into 
the text where you finished coding a keyword like CODEDTOHERE and use the simple 
Ctrl+F (find content) to locate it. 



5. Working with Coded Data 
The primary goal of coding is usually to gather and review and work with all the 
material about a topic or concept. You were coding data in order to be able to see all 
that coded material together, to interpret its variety and to explore its context.  Now to 
the node!  

You can view the coded content of a node in exactly the same way as you view a 
source – in Detail View. Moreover, you can code that content, to other nodes, just as 
if you were coding a source. This is called coding on. 

Working in the Node Detail View 
1. In the List View of any node folder, double click on a node you’ve coded at. 

The coded segments appear in Detail View. Each segment has identifying 
information for the Source and the number of references coded from that 
source at this node.  

Are you still using the online Help? Go to Help and Opening Nodes for full 
detail about what is showing in the pane. 

2. Click on the hyperlink above a segment to open the Source from which that 
segment was coded. 

 
3. Note that any annotations or other links that you made to this segment of the 

source will appear and are live, just as they would be in the coded source. And 
you can place a new link, just as you would if you were in the source from 
which the extract came. 

 



To work with the coded content and its context 
Now explore the options that allow you to see less or more of the text of every excerpt 
from sources that you have coded. 

1. First, adjust what you are seeing for your purposes. You may wish to reduce 
the amount of text you see as a Coding Excerpt, to get a big picture. From 
either the View menu or toolbar, you can select to see all or none of the coded 
text, or just the first line of each excerpt  

           
2. Now to see more of the context of each segment, to understand for example 

what question the speaker was answering when she said that. From View 
menu or toolbar, select Coding Context. Nominate how wide a context you 
want to be shown. NVivo will shows that extra context in the Detail View in a 
pale color.  If you wish to improve the coded selection by coding some of this 
context, select the words to be included, and click Code! This node is waiting 
in the Name slot. 

                      
3. A third option allows you to spread the coding to a wider context without 

first viewing the extra content. From the Coding menu or toolbar, select 
Spread Coding. Again, you can select a small or very wide spread. That 
wider context is coded at the node. Changed your mind? Undo! 

                                   
4. Often when reflecting on a coded passage, you may wish to return to rethink 

the original source. You can jump directly to the place in the source from 
which the coded passage comes. Click on the hyperlink above the passage, or 
from the right mouse context menu, select to Open Referenced Source. 

5. Wondering what else codes this content? Show coding stripes or highlight 
coding, just as you could in the Detail View of a source. Or highlight text, and 
select View>Coding Stripes>Show Nodes Coding Selection. In the Select 
project Items dialog, only those nodes that actually code the selected text are 
available to be viewed as stripes. 



To code on from the Node  
1. Read the node’s content, and consider whether there are other places to code 

it. For example, are there several different motivations for volunteering coded 
at that Free Node?  

2. Select content and code it at a new or existing node, (the processes are just the 
same as for coding a Source). In this way you can develop your ideas beyond 
the original coding. 

To store your ideas about a node 
Continue, reading and coding your data, working with the content coded at your 
nodes, expanding or revisiting context of coded passages. Create nodes as they are 
indicated in the text, for topics you wish to collect data on, or concepts you wish to 
explore.  But remember to store your growing thoughts about that idea. 

1. For each new category you create, unless its meaning is obvious, enter a 
description. You can alter the description at any stage. 

2. If you find you have created a particularly interesting category, you may wish 
to make a Linked Memo for it. Any node can have a linked memo. Revisit the 
previous tutorial for the process of making a Linked Memo. 

 

 

 In all this work, you are creating ideas, which need logging for your analysis. The 
List View of Sources>Memos shows what Linked Memos you have made for your nodes 
(sort them if you wish). Click on the Links folder and then on Memo Links to see and sort 
those belonging to a source or a node. 

 
 



6. Auto-coding 
Not many qualitative research processes can be automated. So it is advisable to check 
which are sufficiently mechanical to be conducted automatically by the computer. 
Obviously, interpretative coding is not one of these processes! But much descriptive 
coding can be automated. (Tutorial 3 covered how to import attributes in tables.)  

Coding of text always involves creating the node, selecting the text to be coded and 
coding. All this can be automated. In this section, the exercise is for auto-coding, 
using formatting of the document by headings. NVivo will make a node for each 
heading and code all the content till the next heading at that node. If you plan to 
autocode by heading, format the source with this in mind, ensuring that the structure 
of your headings is logical. (Don’t use Heading 8 because you like the style, followed 
by Heading 1!)  The node tree hierarchy created will follow the Heading hierarchy (ie 
Heading 1 will be parent, heading 2 will be a child of the previous Heading 1 and so 
on. These techniques do a mechanical coding process. Check the warnings in 
Handling Qualitative Data, Chapter 5 about interpreting mechanical coding.  

To format for autocoding by heading 
When you type your source, either in MS Word prior to importing to NVivo, or in 
NVivo, create headings to name the nodes you wish to code at. Make them brief! 

 If you are typing in MSWord, always use the Style slot to create headings. Making 

it BIG and BOLD does not make it a heading! You can see the headings in a Word 
document by selecting View>Document Map. Anna’s interview looks like this in Word. 

 
Note: two levels of Heading are used for brief names for each question and sub-
question. The full text of the question and the answer are in (different color and font) 
Normal style.  



To do autocoding by heading 
In this example, we will autocode all answers to each topic posed in the interviews, 
creating a node for each topic and coding all the answers at it. 

1. To create the nodes for each interview topic, you need to make a node below 
which all the question nodes can be stored. Here is an obvious use for the Trees 
area of the Node Explorer. Click on Trees, and in the List View, right mouse to 
create a node. (Or use the Project menu, or click on New and select to make a 
new tree node in this folder.) 

2. Name the new node. It’s good practice to note in the Description that these node 
trees are being made by autocoding. 

 
3. Now go to the folder of Sources you want to autocode. (You may wish at this 

stage to import some more sources if there are several with the same formatting.) 
Select the items to be autocoded and select Code>Auto Code… 

or click Auto Code on the Coding bar   

4. In the Autocode dialog, leave the options unchanged and click Select.  

5. In the Select Project Items window, click on your new Questions tree node, then 
OK. Confirm the Autocode instruction with OK.  

6. Now, check your Tree Nodes to see what you’ve done. The List View shows the 
nodes created and named and what coding was done automatically: in the Sample 
Project nine sources were coded at each topic node with one reference from each. 

 



 When auto-coding is completed successfully, this does not mean that the results 
are as you expected! Go to the node for one topic, double click to see in Detail View what 
was coded at it. It should contain each person’s answer to that particular question – no 
more and no less. If it doesn’t, return to check that your formatting was as you 
intended. 

Other ways of autocoding 
Now check the options in the autocode dialog. Did you notice that if you autocode by 
heading, you could specify what heading level you were autocoding? For your 
project, consider how this could be used. For example, in the Sample Project, 
autocoding at Heading 1 coded focus group topics.  By autocoding at Heading 2, Case 
nodes were made coding what was said by each focus group participant. It’s all in the 
formatting! 

The Autocode dialog also allows you to code by paragraph. (Go to Help for details).  

You can also automate coding by text search, using the occurrence of words in the 
text, and NVivo’s ability to code the context you specify.. For instructions on text 
search, go to Tutorial 8. 

 

This concludes NVivo 7 Tutorial 5. For full discussion of the purposes of qualitative 
coding, either interpretatively or automatically, and uses to which these software tools 
can be put, go to Chapter 5 of Handling Qualitative Data. 

You now have data, ideas about your data and have started to relate them by coding to 
gather the relevant data at those ideas.  

Don’t forget to back up your project. The next task is to manage those growing ideas, 
and this will change your project dramatically. 
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