
NVivo 7 Tutorial 4: 

Editing and Linking – Getting “Up From The Data” 
In this tutorial, you will work with just one document in your project, to explore the 
processes of “taking off” or “getting up” from the data. As you read the record, and 
discover new ideas, you will try different ways of storing these in software.  

In Tutorial 5, the processes of coding will be described. Normally, researchers 
combine the storing of ideas with the creating of categories and doing coding – but for 
early steps, it is useful to take them separately. In the following exercises you will: 

• Edit a document 

• Annotate it. 

• Write about it in a memo.  

• Link it to related data. 

• Draw your first ideas in a model. 

The first section of this tutorial, on editing, contains an introduction to the toolbars 
and icons that give access to NVivo’s processes. Unless you are very familiar with 
using toolbars, you will be helped by familiarizing yourself with the shortcuts and 
quick access routes to tasks you may wish to do often. 

Remember, there is almost always a choice of ways of asking NVivo to do something. 
As a reminder to select the processes that suit you best, the alternatives are noted in 
this section, in blue. 

Chapter 4 in Handling Qualitative Data  is about the exciting processes in qualitative 
research involving discovery and exploration of ideas from the data. 

To review what you need to know about the different ways of storing ideas and 
different sorts of links, go to Help. 

Focusing on a document 
To start this tutorial, select a document you already have as a Source in your project.  

Print it out or browse it on the screen, and really read it. Make notes about it as you 
read. 

Now, go back to the start of that document. This time read the text very thoroughly, 
line by line. (As you find material that is interesting, conduct the exercise on “Taking 
off from the data” in Handling Qualitative Data, pp. 70f. In turn, the following 
exercises use each of the ways of storing ideas about the document discussed there.)  

 



 

1. Editing and undoing 
To edit a source 

1. In the List View, create or select the document you wish to edit. Double click 
to open it in the Detail View below. 

2. This window allows you to write text, delete and edit it, as well as to annotate, 
create memos and (see next tutorial) code. 

3. Do some editing. The easiest way to create, add to or comment on the content 
of your data records is of course to edit them. You edit in NVivo very 
similarly to editing in a word processor. 

A note on toolbars 
If you are familiar with your word processor’s toolbars, or those in Outlook, you will 
find NVivo’s have icons for the same main processes and you can manage them 
similarly. Check the special NVivo functions and icons and then move to the next 
section! 

But if you are not used to using toolbars, take time to make these suit you. Qualitative 
research involves a lot of writing. Check that you know what each icon represents, by 
hovering over them. The Main toolbar has familiar icons for cut, copy, paste options, 
and importantly, Undo!  (You can view all the icons and what they represent in the 
Add or Remove Buttons list.) 

 
These main menu options will apply to many processes, not just editing a data record. 
You can cut and paste a node, for example, or undo a change to a model.  

 Clicking the Undo icon will undo the most recent 
process. Clicking the dropdown arrow beside the Undo icon will 
show the last five processes you conducted. Select any to 
undo back to the selected process. 

 

 



 

 
The Edit  Toolbar has icons for familiar word processing tasks. The first slots on this 
toolbar set text styles, font and font size. You may wish to make the toolbars shorter 
and use short cuts instead of icons. To do so, from the Add or Remove Buttons list 
untick any options you wish to hide. (As above, you can view the icons with their 
names by pulling down the Add or Remove Buttons list.) 

From the first slot on the Edit toolbar you can set the style for your text. 

 

 

 

If you use Headings when typing sources in Word, they will be 
imported with the source to NVivo.  

By setting heading level, you give NVivo information that allows 
it to show and autocode the content between headings. 

 

 

Click Customize at the end of any toolbar to hide icons you don’t want to use. But 
first check what they offer you! 

There are four further Toolbars specific to NVivo’s processes, Coding, Links, Grid 
in tables, and ways of Viewing the data. Check how they represent items in the menus 
– those most commonly used. 

You can drag the toolbars, as in Word, to relocate them (with their identifying 
names).  

          
For the next section, on annotating, try using the icons on the Links and View 
toolbars. 



2. Annotating sources 
Editing a data record is not always a desirable way of recording your ideas. If this is a 
record of an interview transcript, or a letter, you are unlikely to want to alter it with 
your comments, or distract from the voice of the respondent. For such commentary it 
is preferable to add an annotation that is linked to the text but does not interrupt it. 
Annotations can be searched using Find or Text Search Query, and when you do 
coding, your annotations will be kept live with coded text.  

 Words in an NVivo annotation cannot be separately coded. So use annotations for 
ideas that belong with the text annotated. A “bigger” idea or interpretation requires a 
memo – whose content can be coded like that of any other source. 

To add an annotation: 
1. In the Detail View, select some words that require an annotation. 

2. From the context menu select Links>Annotation>New Annotation.  

 
OR go to the Links menu, or on the Links toolbar, click the New Annotation icon. 

 
3. The selected text is highlighted. An Annotations tab appears at the bottom of 

the Detail View. Type your ideas… 

 
4. Make more annotations to this source. (Note any selection of text can have 

only one annotation). They will appear, appropriately numbered, in the tab. 
You can always go to an annotation to edit or delete it. And when you print 
the source, you can have annotations printed as endnotes. 

5. If you wish to hide your annotations, while you work in the Detail View, go to 
that View toolbar (or the View menu) and unselect View Annotations. 



3. Writing a memo 
There is an emphasis in all qualitative methods on using memos to capture thoughts 
and insights you have when you are working through your data: ( see Handling 
Qualitative Data, Chapter 4.) 

Memos are full status sources in NVivo. The program sees them differently from 
other sources only because you label them as memos. (The tutorial for Chapter 2 
suggested a first memo called “Volunteering and me”. If you made that, it’s a memo 
simply because you put it in the memos folder. If you are using the sample data, you 
will find several other memos in the Data folder for importing.) 

Any source – including any memo – can be linked to the content of any source. More 
on these “see also” links below. 

Any source or node (with one restriction) can have its “own” Linked Memo, linked 
directly to that project item These memos, “owned” by a document or node, are 
optional, provided for the reflections on just that interview or concept.  

 The restriction?  A Linked Memo can’t itself have another Linked Memo. (This 
restriction protects you from endless tangles!) 

To make a Linked Memo for a source or node 
1. In List View, select the source or node for which you want to create a memo. 
2. From the Links menu, choose Memo Link >Link to New Memo  

 
Or right mouse to get the same options on the context menu. 

3. Name and describe this new memo, (as shown in Tutorial 2), and write your 
thoughts. Remember to insert date and time. Note that the sources that have 
linked memos show icons for these in the List View. 

 
 



4. “See Also…”: ways of linking to related data. 
Qualitative research does a lot of linking – as in most interpretative work, the 
researcher is often wishing to say “See also the data to be found…” (Handling 
Qualitative Data, pp 75-6). Now the data records are becoming “richer”, with your 
own ideas and the links to related material.  

NVivo provides a range of ways of linking for this purpose. As you reflect on your 
data document, you may wish to place a See Also link to a new item, to particular 
words or images in existing data items or in a file that is on your computer (in any 
other software) or a website. Here we will show the first two of these. Explore other 
options using the online Help. 

You can make Memos that are not directly linked to an item, to record your growing 
ideas about themes and concepts that you want to go back and explore later on.  You 
can also of course keep those ideas in a notebook. But unlike the notebook, they can 
be linked directly to the text that gives you an idea, or the place you store it. This will 
matter when you wish to report and log the way you developed your analysis. 

To link from content of a source to a new or existing project item  
1. Open a document in your project. (Or any memo, external, or node).  

2. Highlight some content you wish to link from.  

3. Right mouse click and choose Links>See Also Link>New See Also Link.  

 

 
Or get the same option from the Links menu, or on the Links toolbar, click the New 
See Also Link icon. 

 
4. In the New See Also Link window, specify what you want to link to. If it is a 

new document or memo, this will be created and opened.  



To link to particular content of an item 
If your Option is to link to an existing item, you can select either to link to the whole 
or link to particular content (this is often more useful).  

1. Select to make a “See Also” link to Selected Content. Click Select. 

 
2. NVivo will open that item in a new window. Select the relevant content. 

3. At the bottom of the window, click Select, then in the dialog, click OK. The 
link is made. 

 Note, you can make a link to selected content in the same document, useful if for 
example the speaker changed their mind on an issue later. 

To open the “to” item 
1. At any stage, you can go to the text you linked to from the anchor, now 

marked by a red wavy line under the text from which you made the link.  

2. Click in that anchor, and right mouse to select Links>Open To Item. 



5. Drawing it – the early uses of models 
Throughout qualitative research, models are widely used, with many ways of 
representing hunches, discoveries and theories. (Go to Handling Qualitative Data  
Chapter 4, pp 76f, for suggestions for first uses of simple models as ways of sketching 
and exploring what you think you are seeing in the data.  

You may wish to explore these techniques more fully by jumping to the discussion of 
NVivo’s model tools in the tutorial for Chapter 7. Here, the goal is simply to become 
aware of the possibility of modeling your emerging ideas. 

To start a first model 
Models are made up of shapes and connectors. You start a model by adding these to a 
blank “sheet”. You add new models just like any other project item – from the List 
View, using the Main Menu (Project menu), the New button or the right mouse 
context menu. 

1. In Navigation View, click the Models button and click in the List View. 

2. On the Project menu, click New Model. 

3. In the New Model dialog enter a name and if you wish, a description. Click 
OK. An empty model is displayed in Detail View.  

4. Now add either empty shapes or project items to the model. There are many 
ways to do this: copy/paste, drag and drop, or use the Model menu or right 
mouse context menu. 

5. To connect two shapes, select them both and from the right mouse Context 
menu select New Connector. 

 

 
6. If you add Project items to the model, they are “live”: double click on them to 

open them in Detail View. 



Shaping and changing the model’s appearance 
Appearance does matter, when you are drawing a model to show (to yourself or your 
colleagues) what you are seeing in your project. But beware of how much time you 
can spend on cosmetic touches! 

1. To name your shapes and connectors, double click on them to go to their 
Properties. 

 
2. To color lines or fill shapes, go to the edit menu. 

 
3. Select a connector, then from the Format menu that appears, select Line 

 and you can give your connectors style, weight and color. 

 



Customizing the model space 
A final exercise in using the software concludes this tutorial. Use the menus to 
customize this modeling space to suit you. Models are a clear case for maximizing 
your screen “real estate”.  

1. Remember that you can undock the Detail View - click Docked in the Window 
menu. Now maximize the undocked window, to have your model able to take 
up the whole screen .  

2. From the View menu, select to 
hide the panels to left and right of 
the model – the Model Shapes 
Palette and Model Groups.  

 

 

 

 

 

 

3. You can also Zoom in or out on 
your model. 

 

 
 

This concludes the NVivo 7  Tutorial 4. You now have data, ideas about your data 
and a rapidly growing project. Remember to back up the project file after you exit this 
tutorial! Go to Chapter 4 of Handling Qualitative Data for advice on any of these 
research processes. 

For most researchers, at this early stage in a project, the next task is to start gathering 
material according to topic. For this purpose, you need to code. If you are unfamiliar 
with qualitative ways of coding, go to Handling Qualitative Data, Chapter 5. In the next 
tutorial you’ll learn many ways of doing coding in NVivo. 
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