
NVivo 7 Tutorial 3: 

Managing data: Cases, Attributes and Sets 
For most new researchers an early concern is to learn the ways data are recorded. One 
aspect of this process is to store the context and the sometimes complex information 
that you have to accompany the qualitative data sources you are gathering via 
discussions, interviews or field notes.  

In NVivo, you can store such information as Attributes of your cases, that is, the 
sites or individuals you are studying.  

In this tutorial you will learn how to 

• make case nodes to gather all the material about a case, and create the relevant 
values of variables, such as gender = female;  

• create attributes and store the values for cases in NVivo; 

• import a table of attribute values; 

• and “tidy” sources and nodes into Sets. 

Chapter 3 of Handling Qualitative Data is about the importance of making good data 
records, storing the information about cases which may be essential for your analysis 
and managing the data records.  

For more detail about Attributes and Sets, go to the online Help. 

Thinking nodes and coding 
Nodes are containers for categories in your project, ideas or topics you are interested 
in. They can store references to data segments about any topic or concept. So they do 
what for most researchers is a most basic task of all qualitative projects – bringing 
together the relevant data content for a question or reflection. 

You gather data together by coding those segments at a node. You can then view and 
review all of the data coded at a node. 

Nodes and coding are the subject of the next tutorials. Most of the coding you do at 
nodes will be interpretative – recording your interpretation of the selected data and 
gathering everything about a topic at a node.  

But nodes also have many important data management roles. They can hold all the 
answers to a particular question or store all the results of a query. And most 
obviously, they can hold all references to data about a case. In NVivo 7, any case for 
which you wish to record attributes is given a Case node.  

 In the previous tutorial, when you imported documents, an option was to Code 
sources at cases. If you are importing documents (e.g. interviews) that represent cases 
for which you want to store information, you simply select that option and the whole 
document will be coded at a case node with the same name. 



Cases as data containers 
In the Navigation Window, the second folder is for Nodes. This has five folders for 
different sorts of nodes. One of these is for Cases. In that folder, you can make new 
items. A new case will be represented by a node. 

 
Sometimes, a case is represented by all of and only one document (for example in a 
project where interviews were conducted just once with each person). But this is 
unusual in qualitative research. More often, you have material about a case from bits 
of many sources, (a joint interview with a colleague, field notes on a meeting, bits of a 
focus group). To gather all that material about the case, you code it at a Case Node. 
Then you can see it all together and ask questions about it. You can also store 
information about the attributes of that case – e.g. this is a female, unemployed. Then, 
when you wish to find what unemployed females said about an issue, NVivo can 
locate all of the data coded at cases for which gender (attribute) = female (value).  

To design cases for your project 
For your own project, ask, “What is a Case in this project?” Try these ways to the 
answer: 

• What is the project about?  

• What places or institutions or individuals are you asking about?  

• What classifications are relevant? What sort of information do you 
want to store, and what cases have that information? 

Almost always these questions focus the study. If you are comparing schools, 
according to their socio-economic status and staffing profiles, schools are cases for 
this study. Code all the material about each school at its case node, and store there its 
attributes. Now you will be able to ask the comparative questions. (Did staff of 
working class schools have different attitudes to discipline?) 

As you build more data about a school, you can code it at the relevant case node. The 
attributes recorded for that node will automatically apply to the new material.  

 

 You can arrange cases in sub-groups, each under a more general case node. (A good 
design in the Sample Project would be to make case nodes for “Focus Group Participants” 
and “Interviewees”. And perhaps to have another node for cases of “Companies” working 
with volunteers.) 



1. Bringing more data into your NVivo Project 
To start this tutorial, prepare at least two more data documents, each of which 
represents a case, for example transcripts of interviews, each with one person. If you 
have no such data records yet, create documents from other sources, like website 
descriptions of relevant people.  

To import documents and create case nodes for them 
1. Import more documents into your NVivo project, following the instructions in 

the previous tutorial.  

2. At the Import Source(s) window, click the option to Code sources at cases. 
for any document for which you want to store attribute values. 

 
(If you want to put these new nodes under case nodes for each type of case, click 
Select and select the node, e.g. “Interviewees”, “Focus Group participants”, 
“Companies”). 

3. Click Browse to locate and import the source(s). In the Navigation Window, 
they appear in the Documents List View.  

4. Go to Nodes and click on Cases. You have a new case node for each 
document (with the same name as that document). Click on a case node to see, 
in the Detail View what is coded there. You have coded at that node the entire 
document. 

Now that you have a Case node, you need not restrict the material on this case to just 
one document. When you later get more data about that case, you can code that data at 
the Case node. But for now, the task is to store information about the attributes of that 
case. 

 Note how often Attributes appear in the menus and dialogs. If you store 
information about the attributes of cases, this information will be useable in all Queries, 
“Find” processes and Reports. 



 

2. Using attributes and values 
If you know the attributes your respondents or sites will have (that is, the information 
you’ll want to store about them), you can create them all now, with their values. But 
there is no need to – attributes and values can be created as needed. You can 
individually create attributes and allocate the appropriate values in NVivo. Or, if you 
have substantial amounts of this type of information (e.g. in an SPSS or Excel file) it 
can be imported as a table.  

To create attributes and values
1. In the Navigation Window, select Classifications>Attributes. Right click in the 

List View. From the Project menu, (or the Context menu, or the New button) 
select New Attribute. The New Attribute dialog box is displayed. 

2. Type in the name and, unless it is absolutely obvious what you are recording, a 
description of this attribute. 

3. Select the attribute Type (string, number or date) from the drop-down list.  

4. Click the Values tab to define the values for the attribute.  

 
5. To add each new value, click the Add button and enter value name and optionally 

description.  

6. Check the Default checkbox to specify which value will be allocated to new cases 
as a default (unassigned is usual.) 

 



To assign Attribute Values to Cases 
If you know the information about an individual case, you can easily store it, or at any 
stage change it. 

1. In List View, select the required case. From the Project menu or right mouse 
context menu, click Case Properties. 

2. Click the Attribute Values tab and from the drop down menu for each 
attribute, choose the relevant value. Click OK. 

 

To view and use the Casebook 
Information about attributes is best displayed in a table. NVivo shows the Cases you 
create, and their values for each attribute, in a table called a Casebook. You can 
view the Casebook, import a table to it or export from it the information stored so far. 

1. From the Tools menu, select Casebook>Open Casebook. 

2. The Casebook appears in the Detail View. It may look very small if you have 
only one case with only one attribute! But as your data builds up it will fill up. 
The Casebook for the sample project looks like this. You can print it. 

 
3. Using the filter icons, you can change which rows appear. For example, to see 

only the under 40’s in your sample, filter on the column “age group”:  



 
4. Case characteristics can be changed, when you get more information, or 

perhaps the circumstances of people are altered. At any stage, you can alter the 
value shown for any attribute of a case.  

To alter it to an existing value, select from the drop down list. 

 
To create a new value for a case, select the value in that cell and edit it – if, for 

example, Anna just graduated!  

 

 Note that long names of attributes and values will be shortened in the Casebook – 
for efficiency, keep them as short as possible. 



3. Importing attributes and values 
You can import information to a casebook from any program that handles tables (a 
spreadsheet, data base, statistics package, or just a table you make in MSWord.) 

An attribute table can be created “outside” NVivo and imported.  You can create it by 
exporting attributes from a statistics package or spreadsheet. Or you can type up the 
table in spreadsheet or word processor software. If you have a lot of attributes and 
documents, this is more efficient than creating them in NVivo.  

Please check the Help files for more detailed advice on the formatting of tables and 
the format selected for import 

To create a table for import to a casebook 
1. Type a small table in any program that will create a table (e.g. Word or Excel), 

with the names of your cases down the side. The top left corner cell can be blank, 
or have any word in it (such as Schools or Interviewees). 

Make sure that the case names are the same as the names of case nodes in the 
NVivo project that you want to give these attributes to. If a case name is not 
recognized, NVivo will optionally create a new case node for it. If you don’t yet have 
those case nodes in your project, this may be what you want to do (it’s a quick way of 
creating case nodes). But if you have them slightly different, you’ll get a lot of nodes! 

2. Type names of attributes as the headings of the columns. (Keep them brief.) 

3. Type into this table the names of the values for each case, under each attribute. If 
the attribute isn’t applicable, leave the cell blank. 

You will have a table that looks something like this (start small for a first try). 

 Gender Age Income 

Interview 1 Female Under 20 None 

Interview 2 Male 20-30 Middle  

 

4. Save that table in your table-making software, selecting the options for cells to be 
tab-separated, and the “encoding” to be Unicode Text (*.txt).  

If you prepared your table in Word, check that there are no blank lines above or below 
the table, then on the top menu go to Table>Select>Table, then 
Table>Convert>Table to Text and choose Tabs for separation.  

Now select File>Save As and from Save As Type and Plain Text (.*txt). When you 
close the window, Word asks you to specify File Conversion. Unclick the Windows 
(Default) and instead choose Other Encoding and scroll down to select Unicode. 
This matches the default setting for importing Casebooks into NVivo  

Or: if you leave the File Conversion at Windows (Default), the table will import so 
long as you change the File encoding setting in NVivo to US-ASCII. 

5. Save it somewhere you will find it again! 



To import a table into your Casebook 
1. If you are unsure what you are importing, find and open the file you saved as plain 

text. It looks a lot less tidy than in its table format. But it has the same content as 
the table you saved. The cells are marked by tabs rather than neat lines. This is the 
version that NVivo can import. 

2. In your NVivo Project, choose  Tools>Import Casebook. 

 

3. Click Browse to locate your tab 
separated table. 

4. Check that the File encoding 
setting is correct for the table you 
saved. 

5. Check the Options. You can ask 
NVivo to 

• overwrite existing values 

• create any attributes or 
cases your project doesn’t 
contain. 

 

6. Click OK.  Now open the Casebook and check what you’ve done.       

 If the values didn’t appear as specified in the table you imported, it’s probably 
because you created those attributes prior to import, giving default values (usually not 
applicable) to the cases. If you didn’t ask to overwrite existing values, these will remain. 



4. Using Sets 
This tutorial finishes with the simplest way of managing your data records in NVivo, 
by grouping sources and/or nodes in Sets.  

Whilst Sets are very easily made and used, they are also very effective quick ways to 
gather data in groups and ways into the most subtle and powerful searching processes 
(see Chapter 8). 

To make a Set 
There are many ways to create a set in NVivo and add items to it. Whichever you use, 
what is added is a shortcut to the items you select. 

1. To make a new, empty Set, click in the Sets folder in the Navigation 
Window, click on Sets.  

2. Select (from the Project menu or Context menu or the New button) New Set.   

 
3. Or, to make a new set with items in it, or add items to an existing set, go to 

the List View for those items (either sources or nodes) and select them. Then 
from the right mouse Context menu select or Add to Set or Create As Set.  

 
4. Check the contents of a set by clicking on it in the Sets folder; the sources or 

nodes you put in it will show in the List View. Note, the icons are different – 
these are shortcuts to the item. So you can put a source or a node in any 
number of different sets. 

 
 



5. As a final exercise for this tutorial, think of useful ways you could group your 
documents and nodes for your project’s purposes. In the example above, the 
researcher created a set for all coded sources – a useful way of checking 
whether coding is proceeding as planned.  

 

For most qualitative projects, a useful set is of documents and/or nodes coding 
content that will contribute to your “log trail”, your growing account of the project 
and how it is conducted. Visit the final chapter of Handling Qualitative Data to read 
about the task of doing a “stock take” of your writings about the project. This will be 
much easier if there’s a pointer to each relevant document in a set called “Log trail 
documents”. 

 

This concludes NVivo 7  Tutorial 3.  

Got to Chapter 3 of Handling Qualitative Data for advice on any of these research 
processes. 

You now have a project with data documents and information about their context, and 
have started managing those records in sets. Time to back up.  

In the next tutorial, you’ll learn skills for discovery and handling of the ideas that 
come from the data. 
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