
NVivo 7 Tutorial 2: 

Creating and Importing Sources 
This tutorial is about how to make data records in NVivo7, or import them into your 
NVivo project. There are three ways of doing this – in this tutorial there are 
instructions for each. You will: 

• import one or more records from a word processor file; 

• work in your project, and create a record there;  

• record a summary of what’s in an External record. 

And since at the end of this tutorial you will have a project underway, it concludes 
with instructions for a fourth task: 

• back up this precious project file that records your work! 

Chapter 2 of Handling Qualitative Data is about making qualitative data, the many 
ways of doing so and how to make useful data for your purposes. To review what you 
need to know about documents, go to the Online Help.  

About sources: documents, memos and externals 
NVivo provides three folders for three sorts of Sources – documents, memos and 
externals. 

These are common divisions in a qualitative project. You can make further sub-
folders of your own to hold different types of Sources. Documents, for example, may 
be divided into interviews and focus groups, or memos into theoretical and 
methodological notes. 

If you are working in NVivo you can write early research design records or letters etc. 
in a word processor and import them to your new project as documents or memos. Or 
simply write them within your project.  

And you can make “External” sources to represent other material that you will not 
bring into the project at all but don’t want to lose. 

This tutorial takes you through the steps to import a source, to create a source in 
NVivo and to create an External to record other data. 

As you work through these steps, note that there are always at least two ways of 
getting to the commands you wish to give the software. Familiarity with these 
different ways of working with software will help you find the way that suits you best.  

 Use the List View, as you work. Like the familiar Windows Explorer, it will allow 
you to sort on any of the columns in the right pane. As you bring in more sources, you can 
view your documents or externals in order of size, amount of coding, or date created or 
modified. 



1. Choose how you work in NVivo  
Most tasks can be accessed via the top level menu and also the context menu available 
from the right-mouse button. For most menu items there are short cuts. And for some 
there are icons on the tool bars. For example, there are always three ways to add any 
new item.  

You first need to tell NVivo what you wish to add. You do this by clicking on the 
appropriate folder, and then clicking in the right pane List View. Now what you can 
do for that sort of item will show on the Project Menu and the Context menu when 
you click the right mouse button. 

 

1. Go to the Project menu and 
you will find it offers the 
option to create a new item 
of that sort (or, for 
documents, import them). 

  

 

 

2. Or right click in the List 
View and from the right 
mouse Context menu 
select the option to add a 
new item of that sort (or, 
for documents, to import 
them). 

3. Or just use the New button 
to create this sort, or any 
other sort of new project 
items.  

 

 

 Have you noticed that most 
common actions in NVivo 7 have fast 
keys showing with the menu items? 
It is useful to learn the ones you 
will often want to use. 
 

 

 

 

 

 
 

 
 

 



2. Making sources 
Most of the data sources in most qualitative projects are recorded in text. At this 
stage, you may have early research design documents. Later, you will add transcripts 
of interviews, field notes, survey responses etc.  

As those documents are created, they are usually typed up in your normal word 
processor (here we will assume it’s MSWord.) These word processor documents can 
be imported directly into your project in NVivo. They can be in Word files (.doc) or 
in rich text format (.rtf) or of course in plain text (.txt). If you use Word files, they can 
include pictures or tables or other embedded objects, and you will be able to view, 
code and retrieve this content. 

To import a document 
1. Create a document in your word processor, or locate one you have already typed 

up. Or write an informal one about what you are planning to do and call it 
something like “Project Journal”. Save it as a Word (.doc) file, in a sensible 
location.  

2. In your NVivo project, click on the folder for Sources, and then Documents. 
Click in the List View to show you want to work with the items in that folder. 
From the Project menu select Import Documents. (Or select this command from 
the context menu when you click your right mouse.) 

 
3. Note the options offered. The option to Code sources at cases is covered in the 

tutorial for Chapter 3. If you are importing documents (e.g. interviews) that 
represent cases for which you want to store information, go to that tutorial  
to read about cases. 

4. Click Browse to select the file to import. Navigate to where your first source file 
is located. Select it, and click Open. (If you have prepared more than one 
document, select with Ctrl+click or Shift+click to import many documents at 
once.) Click OK. 

5. The Document Properties are shown. By default, the name of the document is 
the name of the file selected. You can rename or re-describe the document at any 
time by going to its Properties. 



6. Click OK. Your document is imported and its name and details appear in the List 
View.  To read it, double click on the icon next to its name, and its contents will 
open in the Detail View below. 

 
If you wish, you can edit the text, cut and paste text or images, change colors and 
fonts etc just as though you were in a word processor. Close the Detail View at any 
time by clicking on the X in the top right corner of the detail view. 

To add a new source in NVivo’s editor  
Documents or memos can also be introduced into a project by transcribing directly 
into NVivo.  It has a rich text editor, with font controls, and Undo. (Though of course 
it does not have full word processor functions like spelling checkers.)  

Now consider a memo you wish to start. Perhaps a record about your own attitudes 
(prejudices?) to what you are researching? This may be a first important contribution 
to your project’s logging process. Once it’s created in NVivo you can continue to 
enter into it all the changes in your views (or confirmations of them) that should be 
logged.  

As you’ll see in later tutorials, there are huge advantages in typing directly into 
NVivo. Any log trail document can be linked to the data it describes and you can code 
as you type. But for now, just start it. 

1. In the Navigation window, click on the folders for Sources and then Memos. 
Remember to click in the List View to tell NVivo you want to work with the 
items in that folder.  Now you can use the menus as before: click Project>Add 
Memo or use the context menu or the New button.  

2. In the New Memo window, name and optionally describe your memo.  

 Descriptions matter! NVivo gives a description option for most project items. 
Always use this if your purpose in creating an item (like a memo) may be forgotten or 
confused. Teams are much helped by storing descriptions to convey purpose. 



 
 

3. Click OK and the memo is created. The content (currently none) opens in the 
Detail View Type on… you are in NVivo’s rich text editor so use heading styles, 
italics, bold or color as you wish. (Advice on starting a Log Trail document is in 
pp. 43-44 of Handling Qualitative Data.) 

4. It’s important to date the entries in any project log. Note that you can time-stamp 
your entries by selecting Format >Insert> Date/time, or just hitting 
Control+Shift +T. 

  

 
5.  Close the memo as you would in a word processor, by clicking the corner X in 

the title bar. Changes will be automatically saved. 

 



3. Recording external data  
Now for data that is not easily brought into NVivo. As noted in Chapter 2, qualitative 
data records are rarely homogeneous. Much of your data will not be textual.  

For the project you proposed, find some data that you do not want to bring into the 
computer, or can’t – e.g. books, photos, a video, or a box of newspaper cuttings.  In 
NVivo, such data can be represented by “Externals”. If the data represented is a file 
on your computer it’s called an “external file” because it will not be in your project. 
If it’s not on your computer, it’s termed non-file data. 

To add an External for a book 
If you are stuck for some external data, make an External for Handling Qualitative 
Data. Any project requires work with literature, and with an External you can 
reference and keep connections with books and articles. Your summary of each 
chapter, with occasional quotes, is a Source for the project; you can link it to relevant 
data in your project and use coding to find the passages when they are needed. 

The process of creating a new item should be familiar now – select the folder you will 
create it in, (Sources and then Externals) click in the List View to show you want to 
work with the items in this folder.  

1. From the Project menu (or the context menu), choose Add External (or use the 
New button: New>External in this folder). 

2. Type in the name and any relevant details. 

 
3. Click the External tab to specify the file type – this can be a file link or web link. 

If you are describing something (like a book), that is not a file on your computer 
or a URL,  select Other.  



 
4. If you wish, specify what the contents are, the unit (e.g. chapter) and the range 

(e.g. chapters 1-10).  

 
5. Click OK. Your External appears, ready for you to type in summary or comments. 

If you asked for numbered units, you have a template into which you can type the 
summaries of your external data. Each chapter (or other unit that you’ve specified) 
has its own paragraph, so you can put the summary or your comments at the 
appropriate place. 

 
6. As before, just type as though you were in a word processor, changing styles, 

fonts, etc as you wish. You can insert hyperlinks to a website or images from the 
book. In the later tutorials to Chapters 3 and 5, you’ll learn how to link and code 
this different sort of data. 



To add an external for a website 
This is a very common requirement – you have found a site and wish to keep the link 
to it and record your notes on the content. Make an External for that website and you 
can at any time jump to the site from your NVivo project. 

1. You’ve found the website and copied the URL. As above, Add External. Type in 
the name and description. 

 
2. Click the External tab to specify the type and location of this source. Contents or 

units are not relevant for a site – simply leave these options. Click OK. 

3. The External opens in the Detail View and you can type your summary or 
reflections. You can copy and paste images into your External if you wish. 

 
4. From the List View you can at any time Open External File – (from the Project 

menu or Context Menu). This calls the website (if your computer is connected to 
the web). 

 



4. Saving and  backing up 
A reminder: NVivo 7 has saved your project in a single file. This single file can now 
be stored on a CD, Zip Disk, Network drive or emailed to a supervisor or colleague. 

1. Save and Close your project.  

2. In the Welcome Window, select File>Copy Project and follow the directions 
to make a copy of your project. 

OR 

3. Find the project file in your My Documents folder, and make a copy of the 
file. 

4. Now, save the copy somewhere other than on your computer hard disk, for 
backing up. 

 You haven’t created a secure backup until this backup file is copied elsewhere.  A 
backup on your hard drive is a copy not a backup – reflect on what happens to it if your 
hard drive dies or your computer is stolen. 

This concludes NVivo 7  tutorial 2. Got to Chapter 2 of Handling Qualitative Data for 
advice on any of these research processes..  

You now have a project with data, and a good routine for keeping it safe! In the next 
tutorial, you’ll learn how to store different sorts of information. 
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